Skip to content

Update dependency h2 to v4.4.1 - #7

Open
mend-for-github-com[bot] wants to merge 1 commit into
mainfrom
whitesource-remediate/h2-4.x
Open

mend-for-github-com[bot] wants to merge 1 commit into
mainfrom
whitesource-remediate/h2-4.x

Conversation

@mend-for-github-com

Copy link
Copy Markdown

This PR contains the following updates:

Package Update Change
h2 minor ==4.1.0 → ==4.4.1

By merging this PR, the below vulnerabilities will be automatically resolved:

Severity CVSS Score Vulnerability
Medium Medium 5.8 CVE-2025-57804
Medium Medium 5.3 CVE-2026-71554

Release Notes

python-hyper/h2 (h2)

v4.4.1

Compare Source

Bugfixes

  • Performance improvement: remove consumed frames in-place from data buffer.
  • Reject duplicate Host headers in request headers. Thanks to Sunand Mohan for the report.

v4.4.0

Compare Source

API Changes (Backward Incompatible)

  • Support for Python 3.9 has been removed.
  • Support for PyPy 3.9 has been removed.
  • Stream.end_stream() now raises NoSuchStreamError or StreamClosedError exceptions, instead of a generic KeyError.
  • Duplicate content-length headers with different values now raise ProtocolError.
    Previously, the first content-length header was accepted and later conflicting values were ignored. Thanks to Harshal Parekh for the report.
  • Parse content-length headers according to RFC9110 grammar for numbers (1*DIGIT). Thanks to Arkadiusz Marta for the report.
  • backfill from v4.3.0 Convert emitted events into Python dataclass, which introduces new constructors with required arguments.
    Instantiating these events without arguments, as previously commonly used API pattern, will no longer work.

API Changes (Backward Compatible)

  • Support for Python 3.14 has been added.
  • H2Connection.receive_data now accepts any byte-like object that
    implements the buffer protocol, such as bytes, bytearray, and
    memoryview. Existing bytes callers are unaffected.
  • Align CONNECT pseudo-header validation with RFC 9113 s8.3 and RFC 8441 s4.
    Ordinary CONNECT now requires :method=CONNECT and :authority, and
    forbids :scheme/:path. Extended CONNECT (e.g., WebSocket) requires
    :scheme, :path, :authority plus :protocol. (PR #​1309)
  • Fix incorrect substring matching of secure header in cookie and :method.

Bugfixes

  • Fix to allow sending 0 bytes on a stream even if the flow control window is negative.
  • Reject non-zero SETTINGS_ENABLE_PUSH values received from servers.

v4.3.0

Compare Source

API Changes (Backward Incompatible)

  • Reject header names and values containing illegal characters, based on RFC 9113, section 8.2.1.
    The main Python API is compatible, but some previously valid requests/response headers might now be blocked.
    Use the validate_inbound_headers config option if needed.
    Thanks to Sebastiano Sartor (sebsrt) for the report.
  • Convert emitted events into Python dataclass, which introduces new constructors with required arguments.
    Instantiating these events without arguments, as previously commonly used API pattern, will no longer work.

API Changes (Backward Compatible)

  • h2 events now have tighter type bounds, e.g. stream_id is guaranteed to not be None for most events now.
    This simplifies downstream type checking.
  • Various typing-related improvements.

Bugfixes

  • Fix error value when opening a new stream on too many open streams.

v4.2.0

Compare Source

API Changes (Backward Incompatible)

  • Support for Python 3.6 has been removed.
  • Support for Python 3.7 has been removed.
  • Support for Python 3.8 has been removed.
  • Remove mistakenly set max_inbound_frame_size attribute on H2Stream.

API Changes (Backward Compatible)

  • Support for Python 3.11 has been added.
  • Support for Python 3.12 has been added.
  • Support for Python 3.13 has been added.
  • Add an ability to send outbound cookies separately to improve headers compression.
  • Updated packaging and testing infrastructure.

Bugfixes

  • Fix repr() checks for Python 3.11
  • Fix asyncio / wsgi examples.
  • Clarify docs on using curl with http2.

  • If you want to rebase/retry this PR, check this box

@mend-for-github-com mend-for-github-com Bot added the security fix Security fix generated by Mend label Aug 26, 2026
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment

Labels

security fix Security fix generated by Mend

Projects

None yet

Development

Successfully merging this pull request may close these issues.

0 participants